summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRoman Smrž <roman.smrz@seznam.cz>2024-10-13 21:29:01 +0200
committerRoman Smrž <roman.smrz@seznam.cz>2024-11-16 10:12:49 +0100
commitbb2f021704f06909952dfcae45c212b1a496189a (patch)
tree0526afc7eed9796f52b7999cc77e19865fd76447 /CMakeLists.txt
parent116a34391a480d5b55041101b544526ee0dd8e3c (diff)
Update to OpenSSL 3.0 APIHEADmaster
Changelog: Require OpenSSL 3.0 or newer
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4a3727a..4ff8385 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ endif()
find_package(Threads REQUIRED)
find_package(ZLIB REQUIRED)
-find_package(OpenSSL REQUIRED)
+find_package(OpenSSL 3.0 REQUIRED)
find_library(B2_LIBRARY b2 REQUIRED)
add_subdirectory(src)