summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRoman Smrž <roman.smrz@seznam.cz>2021-11-07 10:22:21 +0100
committerRoman Smrž <roman.smrz@seznam.cz>2021-11-07 10:22:21 +0100
commit4fd9548c79512621b3a5de602560b0cae0b97cad (patch)
tree7195f7cf6dcb932c711496d99d727ef4857e5279 /src/CMakeLists.txt
parent293d96b86d84928ae2106d11c0e004a01cc6f5dc (diff)
Explicit filename extensions for CMake
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt32
1 files changed, 16 insertions, 16 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2436914..82c6388 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -3,25 +3,25 @@ include_directories(
)
add_library(erebos
- attach
- channel
- contact
- frp
- identity
- message
- network
- pairing
- pubkey
- service
- state
- storage
- sync
- time
- uuid
+ attach.cpp
+ channel.cpp
+ contact.cpp
+ frp.cpp
+ identity.cpp
+ message.cpp
+ network.cpp
+ pairing.cpp
+ pubkey.cpp
+ service.cpp
+ state.cpp
+ storage.cpp
+ sync.cpp
+ time.cpp
+ uuid.cpp
)
add_executable(erebos-bin
- main
+ main.cpp
)
set_target_properties(erebos-bin