summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..fff6242
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,43 @@
+include_directories(
+ ../include
+)
+
+add_library(erebos
+ attach.cpp
+ contact.cpp
+ frp.cpp
+ identity.cpp
+ merge.cpp
+ message.cpp
+ network.cpp
+ network/channel.cpp
+ network/protocol.cpp
+ pairing.cpp
+ pubkey.cpp
+ service.cpp
+ set.cpp
+ state.cpp
+ storage.cpp
+ sync.cpp
+ time.cpp
+ uuid.cpp
+)
+
+if (NOT CMAKE_SYSTEM_NAME STREQUAL "Android")
+ add_executable(erebos-bin
+ main.cpp
+ )
+
+ set_target_properties(erebos-bin
+ PROPERTIES OUTPUT_NAME erebos
+ )
+
+ target_link_libraries(erebos-bin
+ erebos
+ stdc++fs
+ Threads::Threads
+ ${ZLIB_LIBRARIES}
+ ${OPENSSL_LIBRARIES}
+ ${B2_LIBRARY}
+ )
+endif()