summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0fd7125..2436914 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -19,3 +19,20 @@ add_library(erebos
time
uuid
)
+
+add_executable(erebos-bin
+ main
+)
+
+set_target_properties(erebos-bin
+ PROPERTIES OUTPUT_NAME erebos
+)
+
+target_link_libraries(erebos-bin
+ erebos
+ stdc++fs
+ Threads::Threads
+ ${ZLIB_LIBRARIES}
+ ${OPENSSL_LIBRARIES}
+ ${B2_LIBRARY}
+ )