summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRoman Smrž <roman.smrz@seznam.cz>2022-12-16 21:33:48 +0100
committerRoman Smrž <roman.smrz@seznam.cz>2022-12-16 21:57:38 +0100
commit50ee22fde82dc7429d983171935165866493c38e (patch)
treeb6b22f94de42f277613b01cf48a197fa143a5d34 /CMakeLists.txt
parent3dc8bfbf9be49896407cdc32ad8c9c7789ac9545 (diff)
Disable clang unqualified-std-cast-call warning
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7685ae..4a3727a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,10 @@ set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra")
+if (CMAKE_CXX_COMPILER_ID MATCHES "Clang")
+ add_compile_options(-Wno-unqualified-std-cast-call)
+endif()
+
find_package(Threads REQUIRED)
find_package(ZLIB REQUIRED)
find_package(OpenSSL REQUIRED)